ICANotes - ICANotes Site Down – Incident details

All systems operational

ICANotes Site Down

Resolved
Operational
Started 6 months agoLasted 41 minutes

Affected

ICANotes Sales Site

Major outage from 7:10 PM to 7:51 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    We are aware that www.icanotes.com is currently unreachable and are investigating. This outage does not effect your ability to access ICANotes or ICANotes+.

    If you would like to report details about your issues accessing www.icanotes.com, please send an email to ticket@icanotes.com.