ICANotes - Upload Site Login Issues – Incident details

All systems operational

Upload Site Login Issues

Resolved
Operational
Started 10 months agoLasted 36 minutes

Affected

Other Sites

Operational from 5:09 PM to 5:45 PM

Upload Site

Operational from 5:09 PM to 5:45 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Identified
    Identified

    Our team has identified an issue that is preventing users from logging in to the document upload site (upload.icanotes.com). We are investigating and attempting to resolve as soon as possible.