ICANotes - ICANotes Login Issues – Incident details

All systems operational

ICANotes Login Issues

Resolved
Operational
Started almost 2 years agoLasted about 1 hour

Affected

ICANotes Classic (ehr.icanotes.com)

Operational from 2:00 PM to 2:51 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Investigating
    Investigating

    We are currently investigating reports of login issues with ICANotes. Please keep in mind that chat and call volume will be higher than normal at this time. If you wish to report details of your login issues, please submit a ticket to ticket@icanotes.com.

    Thank you for your patience while we work to restore access as quickly as possible.